What is required to use it?

What is required to use it?

SecurLOCK Equip requires you have a debit card (Debit, World, Business or HSA) issued form Sandy Spring Bank. You will also need an Apple or Android smartphone. After downloading the app, you will be instructed to enter your full account number and other authentication information. Once registered, you can begin using the app immediately.